Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: PHP Fileinfo functions not working

  1. #1
    AlexDudko NNTP User

    PHP Fileinfo functions not working


    I've installed fileinfo PECL extension but I still receive this error:
    > Fatal error: Call to undefined function finfo_open() in
    > /home/alex/public_html/mime.php on line 3

    The strange thing is it's not working if PHP's used as an apache
    module, but if I run
    > php -r "phpinfo();" | grep "fileinfo"

    in terminal I receive
    > /etc/php5/conf.d/fileinfo.ini,
    > fileinfo
    > fileinfo support => enabled

    SLED-11 SP1, php-5.2.14, apache-2.2.10
    Is there a workaround to make it work?


    --
    AlexDudko
    ------------------------------------------------------------------------
    AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
    View this thread: http://forums.novell.com/showthread.php?t=447581


  2. #2
    AlexDudko NNTP User

    Re: PHP Fileinfo functions not working


    And also in cli
    > php -r "print_r(get_defined_functions());" | grep "finfo"
    > [727] => finfo_open
    > [728] => finfo_close
    > [729] => finfo_set_flags
    > [730] => finfo_file
    > [731] => finfo_buffer

    But it doesn't work with apache.


    --
    AlexDudko
    ------------------------------------------------------------------------
    AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
    View this thread: http://forums.novell.com/showthread.php?t=447581


  3. #3
    malcolmlewis NNTP User

    Re: PHP Fileinfo functions not working

    On Mon, 31 Oct 2011 21:36:02 GMT
    AlexDudko <AlexDudko@no-mx.forums.novell.com> wrote:

    >
    > I've installed fileinfo PECL extension but I still receive this error:
    > > Fatal error: Call to undefined function finfo_open() in
    > > /home/alex/public_html/mime.php on line 3

    > The strange thing is it's not working if PHP's used as an apache
    > module, but if I run
    > > php -r "phpinfo();" | grep "fileinfo"

    > in terminal I receive
    > > /etc/php5/conf.d/fileinfo.ini,
    > > fileinfo
    > > fileinfo support => enabled

    > SLED-11 SP1, php-5.2.14, apache-2.2.10
    > Is there a workaround to make it work?
    >
    >

    Hi
    php5-fileinfo from where, it's not in the normal repositories?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 9:35, 3 users, load average: 0.01, 0.07, 0.11
    GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09


  4. #4
    AlexDudko NNTP User

    Re: PHP Fileinfo functions not working


    I've rebuilt an OpenSUSE src package.


    --
    AlexDudko
    ------------------------------------------------------------------------
    AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
    View this thread: http://forums.novell.com/showthread.php?t=447581


  5. #5
    malcolmlewis NNTP User

    Re: PHP Fileinfo functions not working

    On Mon, 31 Oct 2011 22:56:02 GMT
    AlexDudko <AlexDudko@no-mx.forums.novell.com> wrote:

    >
    > I've rebuilt an OpenSUSE src package.
    >
    >

    Hi
    I would look at trying the second one in the list...
    http://software.opensuse.org/search?...ude_debug=true

    I'm assuming the first one in the above list must match your php
    version.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 10:05, 3 users, load average: 0.31, 0.24, 0.17
    GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09


  6. #6
    AlexDudko NNTP User

    Re: PHP Fileinfo functions not working


    malcolmlewis;2150357 Wrote:
    > On Mon, 31 Oct 2011 22:56:02 GMT
    > AlexDudko <AlexDudko@no-mx.forums.novell.com> wrote:
    >
    > >
    > > I've rebuilt an OpenSUSE src package.
    > >
    > >

    > Hi
    > I would look at trying the second one in the list...
    > 'software.opensuse.org: Search Results'
    > (http://software.opensuse.org/search?...ude_debug=true)
    >
    > I'm assuming the first one in the above list must match your php
    > version.
    >
    > --
    > Cheers Malcolm °¿° (Linux Counter #276890)
    > openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    > up 10:05, 3 users, load average: 0.31, 0.24, 0.17
    > GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09


    It suggests to change php version to the OpenSUSE latest 5.3.8 with
    vendor change, though I have 5.2.14.


    --
    AlexDudko
    ------------------------------------------------------------------------
    AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
    View this thread: http://forums.novell.com/showthread.php?t=447581


  7. #7
    malcolmlewis NNTP User

    Re: PHP Fileinfo functions not working

    On Tue, 01 Nov 2011 07:56:02 GMT
    AlexDudko <AlexDudko@no-mx.forums.novell.com> wrote:

    >
    > malcolmlewis;2150357 Wrote:
    > > On Mon, 31 Oct 2011 22:56:02 GMT
    > > AlexDudko <AlexDudko@no-mx.forums.novell.com> wrote:
    > >
    > > >
    > > > I've rebuilt an OpenSUSE src package.
    > > >
    > > >

    > > Hi
    > > I would look at trying the second one in the list...
    > > 'software.opensuse.org: Search Results'
    > > (http://software.opensuse.org/search?...ude_debug=true)
    > >
    > > I'm assuming the first one in the above list must match your php
    > > version.
    > >

    > It suggests to change php version to the OpenSUSE latest 5.3.8 with
    > vendor change, though I have 5.2.14.
    >
    >

    Hi
    So what happens if you grab the php5 src rpm for the installed version
    and rebuild that rpm, it should produce the php5-fileinfo rpm.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 2 days 2:35, 5 users, load average: 0.01, 0.02, 0.05
    GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09


  8. #8
    AlexDudko NNTP User

    Re: PHP Fileinfo functions not working


    I simply can't download it. When I try it asks for authorization and my
    usual Novell account data doesn't work. So I'm not permitted to do
    that.
    May be it's just a Novell problem? It happens that sometimes I can't
    post here (though I'm logged in it still requires authorization).


    --
    AlexDudko
    ------------------------------------------------------------------------
    AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
    View this thread: http://forums.novell.com/showthread.php?t=447581


  9. #9
    malcolmlewis NNTP User

    Re: PHP Fileinfo functions not working

    On Wed, 02 Nov 2011 20:46:02 GMT
    AlexDudko <AlexDudko@no-mx.forums.novell.com> wrote:

    >
    > I simply can't download it. When I try it asks for authorization and
    > my usual Novell account data doesn't work. So I'm not permitted to do
    > that.
    > May be it's just a Novell problem? It happens that sometimes I can't
    > post here (though I'm logged in it still requires authorization).
    >
    >

    Hi
    Clear all the Novell cookies from your browser cache.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 2 days 8:08, 5 users, load average: 0.12, 0.13, 0.13
    GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09


  10. #10
    AlexDudko NNTP User

    Re: PHP Fileinfo functions not working


    I did but authorization is still required. And my Novell account data
    isn't valid to download the package. It's strange, but at the moment I
    can't download anything from Novell.


    --
    AlexDudko
    ------------------------------------------------------------------------
    AlexDudko's Profile: http://forums.novell.com/member.php?userid=100476
    View this thread: http://forums.novell.com/showthread.php?t=447581


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •