I just want to use the old SLES11 behavior and write to /tmp from httpd processes.
I tried this but it did not work:
Code:
SR0005IB02:/usr/lib/systemd/system # ls -l /usr/local/lib/systemd/system
ls: cannot access /usr/local/lib/systemd/system: No such file or directory
SR0005IB02:/usr/lib/systemd/system # mkdir -p /usr/local/lib/systemd/system
SR0005IB02:/usr/lib/systemd/system # cp -p apache2* /usr/local/lib/systemd/system
SR0005IB02:/usr/lib/systemd/system # cd /usr/local/lib/systemd/system
SR0005IB02:/usr/local/lib/systemd/system # ls -l
total 8
-rw-r--r-- 1 root root 493 Nov  5  2015 apache2.service
-rw-r--r-- 1 root root 531 Nov  5  2015 apache2@.service
SR0005IB02:/usr/local/lib/systemd/system # vi *
2 files to edit
SR0005IB02:/usr/local/lib/systemd/system # grep Tmp *
apache2.service:PrivateTmp=false
apache2@.service:PrivateTmp=false
SR0005IB02:/usr/local/lib/systemd/system # reboot
I can of course just edit the apache2* files in /usr/lib/systemd/system but those are overwritten when SUSE updates are applied.
What if the correct way to permanently disable apache2 PrivateTmp?
TIA!