Using the information from this SUSE blog, Introducing the SUSE Linux Enterprise 11 Security Module, I have installed openssl1-1.0.1g-0.47.1. And as the blog says:

Please note that adding this channel does not automatically change existing applications to use openssl 1.0.1. Unless ported they will still use the SUSE Linux Enterprise 11 openssl 0.9.8j version.

So my questions is how can I get Python (Python 2.6.9) that ships with SLES 11 SP4 to use the OpenSSL 1.0.1 version? Do I have to recompile Python? And if so, how is that done so that the distro remains supported by SUSE? Can it be done?

Thank you in advance!