Results 1 to 10 of 10

Thread: ocfs2 mount on boot

Hybrid View

  1. #1
    Rick B NNTP User

    ocfs2 mount on boot

    I am trying to get ocfs2 device to mount on boot. These are 2 SLES 11 SP2
    servers. I am running HAE. I have added the device to the fstab at the end
    like so.

    /dev/sdd /etc/xen/vm ocfs2 _netdev,defaults 0 0

    It will not mount on boot. I am not sure how to address this one. Can't find
    an error. Is there a better solution for this than usig fstab to mount it?
    Obviously this is for a xen setup.

    Thanks


  2. #2
    Rick B NNTP User

    Re: ocfs2 mount on boot

    Rick B wrote:

    > I am trying to get ocfs2 device to mount on boot. These are 2 SLES 11 SP2
    > servers. I am running HAE. I have added the device to the fstab at the end
    > like so.
    >
    > /dev/sdd /etc/xen/vm ocfs2 _netdev,defaults 0
    > 0
    >
    > It will not mount on boot. I am not sure how to address this one. Can't
    > find an error. Is there a better solution for this than usig fstab to
    > mount it? Obviously this is for a xen setup.
    >
    > Thanks


    I think I figured it out at this point.

  3. #3

    Re: ocfs2 mount on boot

    http://www.novell.com/communities/no...#Configuration

    it's for sles10 sp2 but 5.) can be a good starting point.

  4. #4

    Re: ocfs2 mount on boot

    Quote Originally Posted by Rick B View Post
    I am trying to get ocfs2 device to mount on boot. These are 2 SLES 11 SP2
    servers. I am running HAE. I have added the device to the fstab at the end
    like so.

    /dev/sdd /etc/xen/vm ocfs2 _netdev,defaults 0 0

    It will not mount on boot. I am not sure how to address this one. Can't find
    an error. Is there a better solution for this than usig fstab to mount it?
    Obviously this is for a xen setup.

    Thanks
    Bumping this thread. I cant find the answer anywhere else.

    That fstab line doesnt work, boot.local doesnt work.

    How did you do it?

  5. #5
    Rickb NNTP User

    Re: ocfs2 mount on boot

    snemil wrote:

    >
    > Rick B;3506 Wrote:
    >> I am trying to get ocfs2 device to mount on boot. These are 2 SLES 11
    >> SP2
    >> servers. I am running HAE. I have added the device to the fstab at the
    >> end
    >> like so.
    >>
    >> /dev/sdd /etc/xen/vm ocfs2 _netdev,defaults
    >> 0 0
    >>
    >> It will not mount on boot. I am not sure how to address this one. Can't
    >> find
    >> an error. Is there a better solution for this than usig fstab to mount
    >> it?
    >> Obviously this is for a xen setup.
    >>
    >> Thanks

    >
    > Bumping this thread. I cant find the answer anywhere else.
    >
    > That fstab line doesnt work, boot.local doesnt work.
    >
    > How did you do it?
    >
    >


    There is a bug in sles. I can confirm this over and over. I have waited a
    long time for this to be fixed. If you go to /etc/init.d/rcx.d with x being
    number like 3 or 5 and look at the following.

    SXXocfs2 and SXXo2cb. Mine default are S04ocfs2 and S03o2cb. I do a mv with
    them to S12o2cb and S14ocfs2 in the respective runlevel.
    I have this happen at all customer sites as well.

    When you reboot ocfs will finish loading for it to mount. If you run yast
    services config it will put them back and you will have to do the mv again.
    It sucks but that is my only work around I have found.

    Hope that resolves it for you.


  6. Re: ocfs2 mount on boot

    Rick,

    Quote Originally Posted by Rickb View Post
    [...]
    There is a bug in sles. I can confirm this over and over. [...]
    I do a mv with them to S12o2cb and S14ocfs2 in the respective runlevel.
    I have this happen at all customer sites as well.

    When you reboot ocfs will finish loading for it to mount. If you run yast
    services config it will put them back and you will have to do the mv again.
    It sucks but that is my only work around I have found.
    I can't currently help with the original issue - but IMO, a better fix would be to locate the missing dependency and to fix the "Required-Start:" statements (it's in the LSB comments in i.e. /etc/init.d/o2cb). That way, your change would survive any re-configuration of the run levels.

    Regards,
    Jens

  7. #7

    Re: ocfs2 mount on boot

    Thank you.

    Where do you put the actual mount commando?

  8. #8
    Rickb NNTP User

    Re: ocfs2 mount on boot

    snemil wrote:

    >
    > Thank you.
    >
    > Where do you put the actual mount commando?
    >
    >


    I put mine right in fstab as the last line.


  9. #9

    Re: ocfs2 mount on boot

    Quote Originally Posted by Rickb View Post
    snemil wrote:

    >
    > Rick B;3506 Wrote:
    >> I am trying to get ocfs2 device to mount on boot. These are 2 SLES 11
    >> SP2
    >> servers. I am running HAE. I have added the device to the fstab at the
    >> end
    >> like so.
    >>
    >> /dev/sdd /etc/xen/vm ocfs2 _netdev,defaults
    >> 0 0
    >>
    >> It will not mount on boot. I am not sure how to address this one. Can't
    >> find
    >> an error. Is there a better solution for this than usig fstab to mount
    >> it?
    >> Obviously this is for a xen setup.
    >>
    >> Thanks

    >
    > Bumping this thread. I cant find the answer anywhere else.
    >
    > That fstab line doesnt work, boot.local doesnt work.
    >
    > How did you do it?
    >
    >


    There is a bug in sles. I can confirm this over and over. I have waited a
    long time for this to be fixed. If you go to /etc/init.d/rcx.d with x being
    number like 3 or 5 and look at the following.

    SXXocfs2 and SXXo2cb. Mine default are S04ocfs2 and S03o2cb. I do a mv with
    them to S12o2cb and S14ocfs2 in the respective runlevel.
    I have this happen at all customer sites as well.

    When you reboot ocfs will finish loading for it to mount. If you run yast
    services config it will put them back and you will have to do the mv again.
    It sucks but that is my only work around I have found.

    Hope that resolves it for you.
    This works fine. Thank you.
    Im not able to run the "yast services config" that will put the files back to the old state - which command or configuration in yast UI do you run for this to happen?

  10. Re: ocfs2 mount on boot

    Hi snemil,

    > Im not able to run the "yast services config" that will put the files back to the old state - which command or configuration in yast UI do you run for this to happen?

    probably any command that will invoke "insserv" will revert those changes, as insserv creates a "start/stop tree" by checking service interdependencies described in each service file ("### BEGIN INIT INFO" section in the files in /etc/init.d). Rather than setting start/stop sequences by renaming the resulting S*/K*-files, I recommend to add the missing dependencies in /etc/init.d/ocfs2 and /etc/init.d/o2cb. The S/K-numbers depend on the number and type of services installed, giving fixed numbers will only help under specific circumstances.

    Regards,
    Jens

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •