On Fri 30 Dec 2016 05:34:01 PM CST, hdtodd wrote:

This question arose in an earlier thread with other issues. I'm
starting a new thread to separate it from the other issues, and with
some additional information.

I'm running SLES 12, aarch64, on a Raspberry Pi 3. On both Raspbian and
Fedora running on the Pi, the OS saw the K400 Plus keyboard on first
boot, and that keyboard/trackpad worked just fine. On SLES 12, it
didn't see the K400+ (apparently), and I've had to plug in a USB kbd &
mouse to do any work. I'd like to try (again) to get the K400+ working
on SLES -- I'm liking SLES, but I really need to get rid of the USB
devices on my Pi.

I did find and install the Solaar package. WARNING: the version from
the SUSE repository is outdated, even though the version numbers are the
same! Go to the Github repository ( https://github.com/pwr/Solaar ) and
download the zip from there; unzip it; connect to the Solaar master
directory; and run the setup.py program there ("build" and then
"install"). The updated version on Github includes support for the
K400+.

The problem is that Solaar is used to pair and configure Logitech
devices. It isn't the driver for kbd/mouse that the kernel needs. That
driver appears to be loaded as a module, but the keyboard still doesn't
work. The kbd/trackpad are paired to the USB wireless dongle, and
Solaar sees and can configure it just fine, but the kbd doesn't interact
with the OS.

Solaar reports:
Index : 1
Wireless PID : 404D
Protocol : HID++ 2.0
Polling rate : 8 ms (125Hz)
Serial : ABAF0629
Bootloader : BOT 22.01.B0001
Firmware : RQK 63.01.B0014
Other :

modinfo reports:
pi-6:~ # modinfo hid_logitech_dj
filename:
/lib/modules/4.4.21-90-default/kernel/drivers/hid/hid-logitech-dj.ko
author: nlopezcasad@logitech.com
author: Nestor Lopez Casado
author: Logitech
license: GPL
srcversion: F3A9F93C83C7C05995A1FE7
alias: hid:b0003g*v0000046Dp0000C532
alias: hid:b0003g*v0000046Dp0000C52B
depends:
supported: yes
intree: Y
vermagic: 4.4.21-90-default SMP mod_unload modversions aarch64
signer: SUSE Linux Enterprise Secure Boot Signkey
sig_key:
3F:B0:77:B6:CE:BC:6F:F2:52:2E:1C:14:8C:57:C7:77:C7 :88:E3:E7
sig_hashalgo: sha256

So it appears that the driver has loaded, and the USB dongle is paired,
but the kernel isn't seeing the characters come from the kbd/trackpad.

Has anyone gotten this combination to work? I'm pretty sure this is a
simple configuration error on my part, but after much trying, I still
haven't gotten it to work.

Thanks for any suggestions you can offer.
Hi
A missing kernel module - hid_logitech_hidpp

I have a K400r and connected to a laptop running SLED 12 SP2 and it
works fine but uses the above module. Give me a few and will look at
building a module (as a kmp) to see if all works.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!