Good Morning, Malcom,

THANKS! That was exactly what I needed ... I'd never have figured it out on my own. This yielded a working Logitech K400+ kbd/trackpad on SLES 12 running on Raspberry Pi 3:

Code:
(connect to my home directory, download the rpm to which your link points)
su
zypper in kernel-source make gcc rpm-build kernel-syms
su hdtodd (my non-root account)
rpmbuild --rebuild hid-logitech-hidpp-4.4.21-4.1.src.rpm
exit (return to root)
zypper in /home/hdtodd/rpmbuild/RPMS/aarch64/hid-logitech-hidpp-kmp-default-4.4.214.4.21_k4.4.21_90-4.1.aarch64.rpm
(unplug and replug the Logitech USB dongle)
It works!
Note the addition of "kernel-syms" to that first zypper command: first build attempt failed without the symbols.
I have yet to reboot to make sure the module installs at boot time. I will verify that next and post if there's a problem, but I
wanted to get this documented (AND THANK YOU!) first.

I did try two other approaches first, and I'll document those for others, in reverse order.

Second, I tried to follow your instructions and rebuild the modules in /usr/src/linux-4.4.21-90/drivers/hid and then manually install the hid-logitech-hidpp.ko in /lib/modules/4.4.21-90-default/updates/.
Unfortunately, when I tried an insmod, the system reported something about not having symbols (I've lost the exact message) and wouldn't load the module. So I went to your RPM and that
process was successful.

But my first attempt was also successful, except that I've forgotten how to cause modules to be loaded at boot time (or the process
has changed enough over the years and my memory wouldn't have served me). It did generate a functioning .ko file, though.
For those following this, here's what I did. I googled for "building hid-logitech-hidpp" and found this link (among others):
https://www.google.com/url?sa=t&rct=...,d.eWE&cad=rja

And from that followed his link to this page (which is where you really want to go):
http://steamcommunity.com/groups/lin...2224235574471/
and downloaded the driver zip from his dropbox site:
https://www.dropbox.com/s/n4bmw631d4...ivers.zip?dl=0

Copied the .zip to my RPi/SLES system; created a directory for it and unzipped into that directory; did a make (the hidpp.ko file is the last thing made); copied that hid_logitech_hidpp.ko file to /lib/modules/4.4.21-90-default/kernel/drivers/hid (my current SLES version); unplugged and re-plugged the USB dongle in my RPi-3. And VOILA! Both the keys and the trackpad on the K400Plus were functioning. Again, the only problem was that the module wasn't loaded on reboot.

I'm much more comfortable with your RPM build process since I think it yields a result that will be consistent across future updates. Thanks SOOO much for the instructions!

David