On Wed 04 Jan 2017 10:04:02 AM CST, hkuehnemund wrote:

Hello,

I'm running latest updates of SLES on my RasPi. However, Wifi throughput
seems to be quite slow. When running an update with zypper the DL speed
is somewhere between 50-150KB/sec (I have a 120MBit internet
connection). Also, when copying a file from another computer via scp to
the Pi, the speed is around 200KB/sec and after transferring 5-10MB the
connection is terminated and the copy aborts.

Is this a known issue?

Regards,
Hannes


Hi
I see the same, but it's not dropping the scp connection like you see,
what sort of signal/connection are you getting? Also try turning off
the power management as well;
Code:
iwconfig wlan0 power off

iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:"my-ssid"
Mode:Managed  Frequency:2.442 GHz  Access Point:
XX:XX:XX:XX:XX:XX
Bit Rate=65 Mb/s   Tx-Power=31 dBm
Retry short limit:7   RTS thr:off   Fragment thr:off
Encryption key:off
Power Management:off <------
Link Quality=70/70  Signal level=-39 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0   Missed beacon:0
My Bit Rate does go to 72.2Mb/s, that depends on the wireless router
itself and the Bandwidth (40 or 20MHz) and Sideband (Upper or Lower)

If I follow the log (journalctl -f) I do see some errors;
Code:
brcmfmac: brcmf_sdio_hdparse: seq XXX: sequence number error, expect YYY
--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!