Quote Originally Posted by capekeppel View Post
I have an SLES12 SP2 host machine with 3 guests - two are Windows 10 Professional, the third is an SLES12 SP2 Samba server.
For the most part, the system is working perfectly.

However, both of the Windows 10 guests have the same problem - they are trying to update to the latest major Windows 10 build (1607) and they fail every time.
Note that normal Windows updates have all worked fine - just the major ones seem to choke.

I've had this problem since I installed the Windows guests. I installed the original Windows 10 and then the update to Windows 10 build 1511 did the same thing under SLES11 SP4.
I installed a new clean copy of SLES12 and ran the old guest machines, tried to update, but that made no difference.
I then reinstalled the new Windows build 1511 from scratch in new guest machines for both systems.
That worked just fine and everything has been humming along ever since.

However, now it's trying very hard to force the update to 1607, and for these machines I'd like to keep them up to date.
I'd also prefer not to start from scratch again. And I'm expecting another major Windows build soon - I'm sure it will have the same problem.

The host machine is running a fully updated copy of SLES12 SP2 (I just updated from SP1 to see if it would solve the problem).
Both Windows machines are clean installs of Windows 10 build 1511 with a single application running in each.
I also installed Suse VMDP 2.4 in both Windows machines.
They are both Xen (fullvirt) X86_64 machines.

The failure has happened a couple of different ways
1. Update runs normally for a while, and then freezes with cpu utilization at about 25% and never stops.
If I force the machine off and reboot, it says 'Restoring your previous version of Windows'.
2. Update runs normally to 32%, then reboots and says 'Restoring your previous version of Windows'.

Has anyone else seen this problem?

The logs in /var/log/xen don't appear to have any useful information in them.
The windows update logs are also useless - no real indication of what went wrong.

Since Microsoft isn't much help (not supported), does anyone have any suggestions?


I believe you need to temporarily change your Windows 10 guest VM's CPU to CoreDuo for the upgrade to complete.
After the upgrade is complete you can reset the CPU back to what is was.