I'm fairly new to SUSE Manager, and fighting with what seems like a problem introduced in the most recent set of SLES11 patches. Since deploying salt-minion-2015.8.12-27.1 to the managed hosts, the minion stops responding shortly after being started.

SUSE Manager is 3.0.3 (was 3.0.1 - upgrading to current has not changed the symptoms)
Managed systems are SLES11Sp4 with reasonably current patches. The most recent kernel update came out the end of last week, and has not been deployed yet.

Symptoms I see:

1. In the SuMa console, all of the managed hosts are "inactive" because they have not checked in recently.
2. SSH to the host, and "/etc/init.d/salt-minion status" shows "running".
3. Looking at /var/log/salt/minion, the last time/date of something happening corresponds with the last checkin time seen in SuMa.
4. If I restart the minion, I see /var/log/salt/minion update, and the last checked in time in SuMa updates to the current date/time. After the restart, nothing happens if I "tail -F /var/log/salt/minion". Ever.
5. I've kicked the log level up to info, and debug, and nothing continues to happen in the log file after initial restart.

So far, the only thing I've found that works is backdating the salt-minion and salt packages to 2015.8.7-20.1. Then the minion runs fine, checks in every hour, and seems to work fine.

I've been searching, and I can't find any references to anybody else having this problem. It's possible that I'm just spectacularly lucky, I guess, but that seems unlikely. Other than backdating to the version that works, any other good ideas for debugging this?