The following are the build time dependencies for Erlang

libopenssl-devel
libssh-devel
ncurses-devel
unixODBC
unixODBC-devel

Using SLES SDK Repository, I have installed ncurses-devel,unixODBC and unixODBC-devel packages. But while trying to install the other two packages, I am facing issue due to incompatibility in dependent packages.

Error:

libopenssl0_9_8 = 0.9.8h is needed by libopenssl-devel-0.9.8h-30.11.s390x
libssh2 = 0.2 is needed by libssh-devel-0.2-5.14.s390x

Below are the installed packages in my SLES 11 SP3 environment

libopenssl0_9_8 is available
libssh2 - 1.2.9 is available

I tried looking for those packages in patch finder but in vain.

Kindly request you to share your insights in overcoming this issue.

Thanks in advance.

Regards
Gokul
SUSE - Certified Linux Admin