I originally posted this on the sonicwall forum but the more I think about this the more I am lead to believe this is a multi-homed issue.
SLES11 SP1. Heres the problem (stay with me, you will see why I posted here):
site to site VPN (sonicwall 192.168.123.x to pix 192.168.143.x). From the 192.168.143.x side, i need to get to 192.168.123.4; cannot ping this ip, cannot access any resources on this 1 ip. All other ip's on the 192.168.123.x side are reachable and working fine (single NIC configured). Here is what i am seeing on the sonicwall logs when accessing 192.168.123.4 from 192.168.143.x:
Code:
04/27/2012 08:27:07.320 Notice Network Access TCP handshake violation detected; TCP connection dropped 192.168.143.x, 3537, WAN 192.168.123.4, 80, LAN Handshake Timeout

Also, can not reach the 192.168.143.x single address from 192.168.123.x single address:
Code:
04/27/2012 08:43:08.576 Info Network Access ICMP packet from LAN allowed 192.168.124.3, 13927, OPT 192.168.143.x, 8, WAN ICMP Echo, Code: 0

As i look at this log from 192.168.123.x single address, notice he ping comes from 192.168.124 NIC? it appears that it may be making it to the 192.168.143.x single address, the ping is not making it back to the 192.168.123.x single address. This is a multi-NIC server and this ping originates from the OPT side, which also may be a reason the ping is not making it back. Could this be the problem (multi-NIC server)? The 192.168.123 NIC does not have a gateway set: the 192.168.124 NIC does have a default gateway.
Can anyone help me configure the default gateway for the 192.168.123 network?